IBM Support

Known issue: The status of Maximo Assist application remains Active even if the upgrade is not complete

Troubleshooting


Problem

The status of Maximo Assist application remains Active even if the upgrade is not complete.

Symptom

After Assist 8.4.0 is deployed and activated, click Actions button on upper right on the Assist application detail page from MAS 8.8.0 admin dashboard and choose the  administer versions, select version 8.5.0 and click Deploy version 8.5.0. The status of Assist application remains Active to show the deployment complete immediately although the underlying upgrade is not complete.

Cause

MAS Core can detect only whether the Assist application operator is deployed and whether the AssistApp CR instance is ready when Assist is deployed. During upgrade, the Assist application operator is deployed and the AssistApp CR instance is ready. Even though the assist operator is still reconciling the AssistApp CR instance, it is hard for MAS core to determine whether the upgrade finishes or not.
Assist Version to be impacted:
Assist 8.4 (on top of MAS 8.7.x) and Assist 8.5 (on top of MAS 8.8.x)

Resolving The Problem

You can check about the Assist application and workspace activation status and version by using the following steps:
1. You can validate the Assist Deployment status from the Assist Details Page Error! Hyperlink reference not valid..
    You can also check the Assist Deployment status and application version by using the below Red Hat OpenShift client command lines after login your cluster
oc login <OCP_cluster>
oc get assistapp -n {{Assist_project}}
NAME VERSION STATUS AGE
masdev 8.5.0 Ready 73d
2. You can validate the Activation status of Assist from the Assist Details Page Error! Hyperlink reference not valid..
    You can also check the Assist workspace Status by using the Red Hat OpenShift client command line as below
oc login <OCP_cluster>
oc get assistworkspace -n {{Assist_project}}
NAME VERSION STATUS AGE
masdev-main 8.5.0 Ready 73d
If you find that the version of both Assist application and workspace are 8.5.0 (or any version you specify), it indicates the upgrade is complete.

Document Location

Worldwide

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Document Information

Modified date:
26 July 2022

UID

ibm16606151