IBM Support

Known Issue in Maximo Assist 8.6: Cannot extract knowledge from documents that include tables that don't have a border.

Troubleshooting


Problem

When you use the Diagnosis function, you can not extract knowledge from documents that include tables that don't have a border.

Symptom

When you select a document that includes tables that don't have a border, you see the error: Failed to parse the PDFThe related extract table area API returns status code 500 and the message: Internal Error.

Cause

For tables without borders, the open source useto identify tables does not correctly identify table areasThe root cause of identifying this PDF error is that an internal error occurred in the source code. It relies on detected rulings, then finds intersection points, and then determines the extent of the table cell area. In this PDF, the table internal code block is included by the boundary, as detected rulings. Some rulings are filtered out by the principle of improving the detection accuracy, so an error occurs when the code is finding the intersection point.
Maximo Assist version impacted:
Assist 8.5 (MAS 8.8) and Assist 8.6 (MAS 8.9)

Resolving The Problem

If a document has a mix of tables with and without borders, the extraction skips any tables that don't have borders. Extraction successfully completes on tables in the document that have borders. The API returns a status code 200 and the UI displays the tables that were found.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000F83HAAS","label":"Maximo Application Suite-\u003EMAS Applications-\u003EAssist"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.9.0"}]

Document Information

Modified date:
22 November 2022

UID

ibm16839097