IBM Support

JSESSIONID information lost when navigating across servers

Troubleshooting


Problem

When a IBM® WebSphere® Application Server client user navigates across applications running in multiple Application Servers in the same domain, then cookie information might get overwritten causing session loss.

Cause

JSESSIONID value generated by one Application Server might not be known to other server and cookie information will be over-written.

Resolving The Problem

To fix this problem, rename the JSESSIONID cookie name from WebSphere Application Server administrative console.

In the administrative console:

  1. Go to Servers > Application Servers > Server_Name > Web Container Settings > Session management > Enable Cookies

  2. Change the value for session cookie name.

  3. Click OK.

  4. Save changes.

  5. Restart Application Server

  6. Regenerate plug-in configuration file.

  7. If running remotely, copy plug-in to remote server.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Sessions and Session Management","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.0;8.5","Edition":"Base;Express;Network Deployment","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSNVBF","label":"Runtimes for Java Technology"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Java SDK","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21225834