IBM Support

JazzSM DASH HA: servers are unable to connect to cluster after DB2 11.1 was patched with special DB2 build and fails to connect with "SYSIBM:CLI:-805". SQLSTATE=38553 error message

Question & Answer


Question

After WebGUI/JazzSM servers that are part of the HA environment using the DB2 11.1 database that was patched with a special build are being restarted, these are no longer connected to the cluster and the following error messages are being thrown:

SystemErr R com.ibm.db2.jcc.am.SqlException: Routine "SYSIBM.SQLTABLES" (specific name "TABLES") has returned an error SQLSTATE with diagnostic text "SYSIBM:CLI:-805".. SQLCODE=-443, SQLSTATE=38553, DRIVER=3.72.54
Routine "SYSIBM.SQLCOLUMNS" (specific name "COLUMNS") has returned an error SQLSTATE with diagnostic text "SYSIBM:CLI:-805".. SQLCODE=-443, SQLSTATE=38553, DRIVER=3.63.75

Cause

This is because DB2 11.1.x database was patched with special build but the db2schema.bnd was not bound to database again.

Answer

DB2 keeps track of the last fix installed in the internal SYSBOOT catalog table. When the database first starts up, the current fix pack level is compared to previous version and triggers auto-bind if the levels are different. This is done to avoid having to rebind on every first connect.

However this mechanism does not work in the case of a special build where the fix pack level has not changed. In such a case, if a rebind is required (i.e. special build contains changes to one of the system packages) customers need to manually do the rebinding identified in step 6 of this page:

https://www.ibm.com/support/knowledgecenter/SSEPGG_11.1.0/com.ibm.db2.luw.qb.server.doc/doc/t0024995.html

Hence, the solution to fix the JazzSM HA cluster problem is to re-bind the db2schema.bnd to database.  The steps that can be followed are described for DB2 within the following technical note as well:
https://www.ibm.com/support/pages/node/408503

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSEKCU","label":"Jazz for Service Management"},"ARM Category":[{"code":"a8m500000008bv6AAA","label":"DASH->DASH UI Services - HA Category->DUIS-HA Configuration"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

DASH
DB2

Document Information

Modified date:
30 April 2020

UID

ibm16203759