IBM Support

Japanese characters are garbled when viewing Log File in Optim Performance Manager Web Console

Troubleshooting


Problem

Japanese characters in log files (For example: DS_System.X; HealthSnapshotLogger.X; JobManagerLogger.X) are garbled when using "View Log" or "View in Browser" in OPM Web Console

Symptom

Japanese characters in log files (For example: DS_System.X; HealthSnapshotLogger.X; JobManagerLogger.X) are garbled when using "View Log" or "View in Browser" in OPM Web Console. But Japanese characters are displayed well with UTF-8 encoding in log files on the OPM host.

(Take "HealthSnapshotLogger.X" as an example)

(1) When Web Browser Language is English

(1.1) Japanese characters are garbled when using "View Log" in OPM Web Console.



(1.2) Change encoding with any Japanese Encodings(like UTF-8; Shift-JIS; EUC-JP), then click "View in Browser", Japanese characters are still garbled.


(2)When Web Browser Language is Japanese

(2.1) Japanese characters are garbled when using "View Log" in OPM Web Console.



(2.2) Change encoding with any Japanese Encodings(like UTF-8; Shift-JIS; EUC-jp), then click "View in Browser", Japanese characters are still garbled.



(3) But Japanese Characters are displayed correctly with UTF-8 encoding when viewing the log file from OPM host side.

Cause

OPM Web Console doesn't know what codepage is used.

Resolving The Problem

Work-around:
User can clearly view the internal logs (which contain Japanese Characters) from OPM Server side.

[{"Product":{"code":"SSBH2R","label":"InfoSphere Optim Performance Manager for Db2 for Linux, UNIX, and Windows"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"5.3.1","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
08 July 2021

UID

swg21693707