IBM Support

Issue with upgrading the Rational DOORS database server if you have more than one instance of the database server on your computer

Troubleshooting


Problem

If you have more than one instance of the Rational DOORS database server on your computer, and you upgrade to version 9.5, only one instance of the database server is upgraded correctly.

Cause

The installer does not automatically upgrade the second and any other instances of the database server.

Diagnosing The Problem

After upgrading, select Administrative Tools > Services, and scroll to the entries for the Rational DOORS database server services. Only the first instance will be present. There will be no entries for your other database server instances.

Resolving The Problem

Manually reinstall other instances of the database server:

  1. Open a command prompt and navigate to the bin directory of your 9.5 Rational DOORS database server installation.
  2. Type doorsd -minstall -p portnumber -s serverdata. Replace portnumber and serverdata with the port and server data location that you want to display as a service again in 9.5.
    For example:
    doorsd -minstall -p 36699 -s c:\DOORSdata\database2

When you reopen the list of services, the other Rational DOORS database server services will be added.

[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21617040