Troubleshooting
Problem
This technote identifies a potential cause and resolution to the "Error occurred while getting the baseline data of the Package:..." error that appears when you try to open and view an existing baseline in IBM Rational RequisitePro.
Symptom
When you try to open and view a baseline in IBM Rational RequisitePro Baseline Manager, you face following error.
The full "Compare Baseline" error message is as follows:
Error occurred while getting the baseline data of the package: <package name>
Reason:
An invalid XML character (Unicode: 0xe) was found in the element content of the document.
Eventually, you can not proceed any further.
Cause
By a simple copy and paste operation from PDF document to a Microsoft Word document in RequisitePro, invalid character (page break code) has been inserted into IBM RequisitePro Database. As a result, any baselines from this contaminated RequisitePro Database also contains this invalid character. Baseline is not able to be processed further in IBM Rational RequisitePro Baseline Manager.
Resolving The Problem
Instructions for resolving the problem
Notes:
- Prior to applying any of the following steps, make extra backup copies of current existing baseline.
- Apply the instructions on an extra backup copy of baseline, not on the production baseline directly.
- If you lose any production baselines due to not applying instructions on backup set, IBM is not subject to any responsibility for data loss.
Find all invalid XML characters in baseline (Unicode: 0xe)
- Open Windows Explorer and locate to your testing baseline folder.
- Click on Search on Toolbar.
- Choose All files and folders.
- Copy the contents (invalid character ) of attached text file
- Paste it into in "A word or phrase in the file:" of Windows Explorer.
- Click Search.
- Open all files found using Microsoft Notepad and delete all invalid characters and save it.
- All baseline files are ready-only, so change the file attribute before editing.
- Right-click on file found > Properties
- Untick on "Read-only" and click "OK"
- Try to open and view baseline in RequisitePro Baseline Manager.
Contact IBM Rational Client Support with original (unmodified) baseline, if you have any concerns or further assistance is required.
All source code and/or binaries attached to this document are referred to here as "the Program". IBM is not providing program services of any kind for the Program. IBM is providing the Program on an "AS IS" basis without warranty of any kind. IBM WILL NOT BE LIABLE FOR ANY ACTUAL, DIRECT, SPECIAL, INCIDENTAL, OR INDIRECT DAMAGES OR FOR ANY ECONOMIC CONSEQUENTIAL DAMAGES (INCLUDING LOST PROFITS OR SAVINGS), EVEN IF IBM, OR ITS RESELLER, HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. |
---|
Was this topic helpful?
Document Information
More support for:
Rational RequisitePro
Software version:
7.0.1, 7.1
Operating system(s):
Windows
Document number:
129015
Modified date:
23 June 2018
UID
swg21407240