Troubleshooting
Problem
Running the MobileDbGeneration crontask results in an invalid path error in the cron task history dialog.
Symptom
The MobileDbGeneration crontask history shows an error similar to the following, which prevents the preloaded database from creating.
Crontask instance ID: MobileDbGeneration.MobBedford; Template user: MAXADMIN; Template user insert site: Bedford; Person groups associated: BEDFORDMOB; -------------------------------------- Error list: -------------------------------------- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Error message: path to 'D:\mif\maximo\mobileDB\MAXADMIN\maximoMobile.db': 'D:\' does not exist;
Cause
Maximo mobile uses the mxe.int.globadir system property to set the location for the preloaded database to build before the upload of the mobiles into the database. If this path is incorrect the crontask fails to run.
Resolving The Problem
To resolve the issue, perform the following steps.
- Open the System Properties application
- Filter for mxe.int.globaldir
- Update the value to a valid path
- Check the box next to the property and perform a live refresh.
On the next crontask, run you will see that the error no longer exists and the mobile db will start building
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hAgaAAE","label":"Maximo Application Suite-\u003EMAS Applications-\u003EMobile"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.10.0;8.8.0;8.9.0"}]
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Document Information
Modified date:
29 May 2023
UID
ibm16999143