IBM Support

Invalid Login Response error when accessing Cognos Analytics via SSO

Troubleshooting


Problem

After running the automatic script to set up SSO, trying to access Cognos Analytics using SSO displays an "Invalid Login response" error.

Cause

1. Cognos Configuration is missing the gateway application in the URI.
2. The Dispatcher URI's for Gateway are referencing the legacy dispatcher.
3. The Dispatcher URIs for external applications are also referencing the legacy dispatcher URI.

Diagnosing The Problem

All the security namespace settings in IBM Cognos Configuration and the IIS rewrite rules are configured correctly.

Resolving The Problem

Steps:

· Open IBM Cognos Configuration.

· Click on ‘Environment’ in the Explorer panel.

· Change the ‘Dispatcher URI's for Gateway’ such that it is of the following form: http://servername:portnumber/bi/v1/disp

· Change the ‘External Dispatcher URI’ such that it is of the following form: http://servername:portnumber/p2pd/servlet/dispatch

· Make sure that all the URIs use the fully qualified domain name and not localhost.

· Change the Gateway URI such that it is of the following form: http://servername:80/aliasname/bi/v1/disp

· Restart services.

Related Information

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.9;11.0.8;11.0.7;11.0.6;11.0.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22013566