Troubleshooting
Problem
When login in to Cognos there is a error message "Invalid Login Response"
Cause
Bouncy Castle Provider could not be loaded.
Environment
IBM Cognos Analytics 11.0.x not using the shipped JRE.
Diagnosing The Problem
Using the Developer Tools in the Browser will show an Request which returns an HTTP 500 error. In the details you see the message: java.lang.NoClassDefFoundError: org.bouncycastle145.asn1.ASN1Sequence
Resolving The Problem
Copy the file <cognos_installation_path>/jre/lib/ext/bcprov-jdk14-145.jar to external JRE <JAVA_HOME>/jre/lib/ext/bcprov-jdk14-145.jar. Open Cognos Configuration and click Save. Restart the Service and the Login will work.
[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg22003326