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Invalid LDAP Credential error when performing LDAP Login with IBM Filenet IDM Web Services

Troubleshooting


Problem

When performing an LDAP login using either IBM Filenet IDM Web Services or IBM Filenet IDM Open Client, login fails with Invalid LDAP Credential.

Symptom

IDM Web Services opens a window with the following message:


    Invalid LDAP Credential
    Number:0x80046A07
    Native Code 0x31
    Source IDM exception

Cause

As part of the LDAP login process, the user must be validated by IDM Web Services against the LDAP server. If the configuration options for LDAP are not correctly set, the server cannot be located, and the error will occur even when the user name and password is correct.

Resolving The Problem

Run IDM Configure, select Additional Preferences, and expand Libraries, LDAP Settings. Set them as follows:

  • Enable LDAP for the whole website - Yes
  • Server name - Put the LDAP server name itself. Do not put the domain or any additional information.
  • Distinguished name/User principal name suffix
    • If the LDAP server uses Microsoft Active Directory, put the principal name suffix (for example, eng.filenet.com)
    • If not using Active Directory, such as with iPlanet, or NDS, put the distinguished name suffix (for example, dc=eng,dc=filenet,dc=com)
  • Port Number - 389 unless the LDAP server uses a custom port
  • Server Type - Select the correct Server Type. If the LDAP server has Active Directory installed, use MS Active Directory, even if other choices apply.

[{"Product":{"code":"SS5USE","label":"IBM FileNet Web Services"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"WEB Services","Platform":[{"code":"PF033","label":"Windows"}],"Version":"4.0;4.0.1;4.0.2","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
21 January 2022

UID

swg21303602