Troubleshooting
Problem
Image map creation fails with an error when you try to upload a JPEG image file in the administrator client of IBM Intelligent Video Analytics (IBM IVA).
Symptom
- Log on to the administrator client of IBM IVA.
- Click the Maps tab.
- Click Clear to create a new image map, enter the required information, and click Save.
- Select the image map in the grid, click Image, and when prompted, browse to and select a JPEG image to load.
RESULT: The source image file fails to upload to the image map, and the following Java exception error occurs:
java.awt.color.CMMException: Invalid image format
Note: The problem only occurs with certain JPEG files. Most JPEG files can be uploaded successfully.
Cause
This problem occurs if the JPEG image that you are trying to upload does not conform to the International Color Consortium (ICC) specifications. The Java runtime image libraries that are used by IBM IVA can process JPEG images only if they conform to the ICC standard specification.
Resolving The Problem
Use either one of the following solutions to work around the problem:
1. Select an alternative image source file, such as a PNG, GIF, JPG or a JPEG that does confirm to the ICC standard specifications.
2. Use an image editing tool to edit the problematic JPEG image, save it again as a JPEG file, and then retry to upload the image in an IBM IVA image map.
Important: The image map feature is available in IBM IVA 1.6.0.1 or later. For more information about how to create an image map in IBM IVA, see the configuration section of the product documentation.
Related Information
Was this topic helpful?
Document Information
Modified date:
14 October 2022
UID
swg21696784