Troubleshooting
Problem
User runs a report to PDF. An error occurs. The problem is intermittent.
Symptom
File does not begin with '%PDF-'.
Cause
There are many possible causes for similar errors.
- TIP: For more examples, see separate IBM Technote #6327347
This Technote specifically relates to the (rare/unlikely) scenario where the cause the setting "Temporary objects location".
More Information
When a user runs an interactive report, the report server sends a request to the Content Manager, asking it to store the report output in the session cache for the user.
- In versions of Cognos BI *before* 10.1.1, this cache information was stored inside the Content Store (database).
- Beginning with BI version 10.1.1, these user session files are stored on the report server's local file system. This is to reduce the processing load on the Content Manager.
NOTE: If your system was originally running an older version (for example Cognos BI 8.5) and you have now upgraded to 10.1.1, then (by default) your user session files are still stored in Content Manager (not as files).
In some early versions of BI, storing these file on the report server can cause intermittent errors/problems.
Environment
Early versions of Cognos BI 10.x, especially if they are brand-new installations (the server was not upgraded from an earlier version of Cognos BI, for example 8.x).
Resolving The Problem
Modify the setting "Temporary objects location" from the current ("ServerFileSystem") to the value "Content Store".
Steps:
1. Launch IBM® Cognos Connection.
2. In the upper-right corner, click Launch, IBM Cognos Administration:
3. On the Configuration tab, click Dispatchers and Services.
4. Click the Set Properties - Configuration button (in the upper right corner):
5. Click Settings
6. From the Category menu, click Tuning.
7. Change the setting for Temporary objects location to be 'Content Store':
8. Click OK.
9. Test.
Steps:
1. Launch IBM® Cognos Connection.
- TIP: By default, this is the following website URL: //servername/ibmcognos
2. In the upper-right corner, click Launch, IBM Cognos Administration:
3. On the Configuration tab, click Dispatchers and Services.
4. Click the Set Properties - Configuration button (in the upper right corner):
5. Click Settings
6. From the Category menu, click Tuning.
7. Change the setting for Temporary objects location to be 'Content Store':
8. Click OK.
9. Test.
Related Information
[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Studio","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
08 September 2020
UID
swg21673911