Troubleshooting
Problem
This document introduces a setting to resolve an intermittent 502-Proxy Error problem. The symptoms were reported in a Cognos Analytics (CA) 11.0.7 and IBM HTTP Server (IHS) 8.5.5 environment. The IHS server was configured following the steps from the documentation at;
https://www.ibm.com/support/knowledgecenter/SSEP7J_11.0.0/com.ibm.swg.ba.cognos.inst_cr_winux.doc/t_gwapache22orihs7.html#GWApache22orIHS7
Symptom
Intermittently the users will receive a 502-Proxy error when clicking a folder in package items while editing a report.
Cause
A race condition happens while an http session is being terminated and a user tries to re-use it.
Environment
This problem was discovered in a Cognos Analytics 11R7 environment using and IHS 8.5.5 server. The issue is non OS specific and most likely need a complex network infrastructure (proxies, load balancers and firewall) that causes lag in the network traffic.
Resolving The Problem
The following settings are recommended.
1. ProxyPass in httpd.conf of IHS
Modify IHS httpd.conf file as following
From:
ProxyPass http(s)://<app_server:port>/bi
To:
ProxyPass http(s)://<app_server:port>/bi smax=0 ttl=28
2. httpOptions CookiesConfigureNoCache in server.xml
Modify following 2 lines of <Cognos Install>/wlp/usr/servers/cognosserver/server.xml.
2-1.
From:
<httpOptions CookiesConfigureNoCache="false" AutoDecompression="false"/>
To:
<httpOptions CookiesConfigureNoCache="false" AutoDecompression="false" maxKeepAliveRequests="-1"/>
2-2.
From:
<httpOptions CookiesConfigureNoCache="false" AutoDecompression="false" keepAliveEnabled="false"/>
To:
<httpOptions CookiesConfigureNoCache="false" AutoDecompression="false" keepAliveEnabled="false" maxKeepAliveRequests="-1"/>
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Document Information
Modified date:
19 September 2018
UID
ibm10732115