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The installed product does not match the installation source(s)

Troubleshooting


Problem

This technote explains why attempts to install an IBM® Rational® ClearCase® iFix or Fix Pack on Microsoft® Windows® results in the error []The installed product does not match the installation source(s)[] and provides steps to resolve the issue.

Cause

Attempts to add or remove a component of ClearCase for an existing installation (see technote 1255007) results in the following error:






Note: Attempts to click Browse and cd to the release area folder and selecting the ClearCase msi file (1033_ClearCase.msi for example) results in the following error:



Click OK





Click Cancel




Click OK



Click Exit




In order to change the current ClearCase installation options using the Add/Remove Programs, you need to reference the installation location.

The cause of this error results from the Release Area version not being in sync with the version installed on the host.

For example, in this case, the client has ClearCase 7.0.0.1 installed (installed update to the local host), but the release area from which the client was installed was only at version 7.0.

Resolving The Problem

In order to change the current installation options using the ADD/Remove Programs method, your release area must be at the same patch level as the client.

Option #1: Update the release area to incorporate the same patch level as the client and attempt to change the client installation option again.

Option #2: Uninstall the client and reinstall from the release area selecting the preferred options.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21254998