IBM Support

Installation issues with ClearCase and ClearQuest Fix Packs on Windows 2003 Server

Troubleshooting


Problem

This technote explains how to resolve errors than can occur when installing a FixPack for IBM Rational ClearQuest, ClearCase or ClearCase LT on a Microsoft Windows 2003 Server. This problem affects the application of FixPacks 7.0.0.2 through 7.0.0.9, and 7.0.1.1 through 7.0.1.12.

Symptom


There are three scenarios that could cause errors during the installation of the 7.0.0.2 through 7.0.0.9, and 7.0.1.1 through 7.0.1.12 Fix Pack releases, on Microsoft Windows 2003 Server platforms. These errors could also occur with the iFixes for these FixPacks.

Scenario 1
The following error occurs when installing the Fix Packs on ClearQuest:

Error 1758 File <archive file> was rejected by digital signature policy.

The following error occurs when performing the same activity on ClearCase or ClearCase LT:

Error 1718 File <archive file> was rejected by digital signature policy.


Scenario 2
The following error message occurs when installing the Fix Packs in Microsoft Windows 2003 Server environments with installed RAM of 2 GB or greater:

! The Installation source for this product is not available. Verify that the source exists and that you can access it.




The error can also occur in some double byte language environments, such as Traditional Chinese and Japanese, with RAM 1 GB or greater.

Scenario 3 - ClearCase and ClearCase LT Only

Applying the Fix Pack from the command line results in the following entry in the installation log:

Example Syntax:



msiexec /p 7.0.0.2-RATL-RCC-WIN-en-US-FP01.msp /l*vx fp1_install.log


LOG:

MSI (c) (5C:08) [12:20:50:019]: The installation of c:\7.0.0.2-RATL-RCC-WIN-en-US-FP01.msp is not permitted due to an error in software restriction policy processing. The object cannot be trusted.

File c:\DOCUME~1\LOCALS~1\Temp\1\3da0247.msp was rejected by digital signature policy.
The installation source for this product is not available.  Verify that the source exists and that you can access it.

c:\7.0.0.2-RATL-RCC-WIN-en-US-FP01.msp
MSI (c) (5C:08) [12:21:05:551]: Product: IBM Rational ClearCase -- Installation failed.

Note: These problems occur on Microsoft Windows Server 2003 and R2 platforms. For more information regarding Windows Server 2003 support, see the ClearCase and ClearQuest support matrices.

Cause

This occurs because of the problem reported in Microsoft Knowledge Base article KB925336.

Resolving The Problem

To resolve these errors, perform the following steps:

  1. Apply the Windows update provided in the Microsoft KB article KB925336.

  2. Open the Local Security Settings GUI. Start > All Programs > Control Panel > Administrative Tools > Local Security Policy

  3. Click Software Restriction Policies.

    Note: The right pane may list "No Software Restriction Policies Defined".



  4. Right-click the Software Restriction Policies, and select New Software Restriction Policies



  5. Double-click on the Enforcement entry to open the Enforcement Properties dialogue
    1. Under the Apply software restriction policies to the following:
      section, keep All software files except libraries (such as DLLs) options checked.

    2. Under Apply software restriction polices to the following users:
      section, change to All users except local administrators and click Apply and OK.




  6. Close all windows and exit the Administrator Tools

  7. Restart the server.

  8. Restart the Fix Pack installation. The error should no longer occur and you should be able to proceed with the installation.

[{"Product":{"code":"SSCTQH","label":"Rational Common Components"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Rational Common Installer","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.0.2;7.0.0.3;7.0.0.4;7.0.0.5;7.0.0.6;7.0.0.7;7.0.0.8;7.0.0.9;7.0.1.1;7.0.1.10;7.0.1.11;7.0.1.12;7.0.1.2;7.0.1.3;7.0.1.4;7.0.1.5;7.0.1.6;7.0.1.7;7.0.1.8;7.0.1.9","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
29 September 2018

UID

swg21289965