Troubleshooting
Problem
When installing Cognos Analytics server or Framework Manger, InstallAnywhere exits after loading 100%
Symptom
Cause
The JVM gets into a bad state due to values passed from the variables which do not allow Cognos installer to launch.
Diagnosing The Problem
Windows process monitor shows the following error:
The process 'C:\Users\TEMP\Desktop\ca_installer_win_2.0.exe' exited with exit code 3004. The creation time for the exiting process was 0x01d6a892530a9769.
Resolving The Problem
1. Right-click My Computer
2. Click Properties > Advanced system settings > Environment Variables
3. Locate IBM_JAVA_OPTIONS and JAVA_TOOL_OPTIONS in this list
4. Backup the values to a notepad
5. Remove the environment variables
6. Restart the operating system
7. You should be able to successfully launch the installer now
Document Location
Worldwide
[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3yAAC","label":"Installation and Configuration"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]
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Document Information
Modified date:
29 November 2020
UID
ibm16373032