IBM Support

InfoSphere Information Server: OS のエフェメラル・ポートと DB2 のポート

Question & Answer


Question

リポジトリ・データベース用 DB2 を手動で停止・開始をする運用を行っています。まれに DB2 を開始してもネットワーク上から認識されない事象が発生し、OS を再起動するまで解決しない場合があります。どのような可能性が考えられますか?
※なお、この事象はおもに Windows で発生しますが、AIX、Linux でも潜在的に発生する可能性があります。

Cause

DB2 が使用しているポート 50000 が OS のエフェメラル・ポートの範囲に含まれており、DB2 停止中に他のプロセスがポート 50000 を使用し、DB2 の再起動時にポートが競合する場合があります。

Answer

次の3通りの対策のうち、いずれかを実施してください。
(1) ポート 50000 をエフェメラル・ポートの範囲から除外する
除外方法の詳細は、DB2 の Technote 7060273 を参照してください。
 
(2) レポジトリ・データベース用 DB2 のポートを変更する
製品ドキュメントの「メタデータ・リポジトリー・データベースのホスト名およびポートの変更」の項目を実施してください。変更箇所が多く、慎重な作業が必要なので、特別な理由がないかぎり (1) の対策を行ってください。
(3) 新規インストール時に DB2 のポートを変更する
既にインストール済みの環境では対策できませんが、新規にインストールするときに、「IBM DB2 インスタンス・ユーザー」の画面で、インスタンス・ポート番号にエフェメラル・ポート範囲外のポート番号(例 25000)を指定してください。なお、DB2 は V11.5.6 以後デフォルトのポート番号を 50000 から 25000 に変更しています。
2023-10-31: 初版
2023-12-28: 最新版

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSZJPZ","label":"IBM InfoSphere Information Server"},"ARM Category":[{"code":"a8m500000008XIQAA2","label":"Xmeta Repository Database-\u003EDB2"}],"ARM Case Number":"TS014302107","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.7.0;11.7.1"}]

Document Information

Modified date:
28 December 2023

UID

ibm17060329