IBM Support

Infosphere Guardium STAP not collecting traffic or Inspection Engine cannot be configured

Troubleshooting


Problem

Infosphere Guardium STAP has been installed on a Linux System and there is no traffic being seen on the collector from it or the inspection engine configuration page has some of the settings missing.

Symptom

The STAP will not be collecting traffic, when you try to install an inspection engine some of the setting options will be missing.

Cause

The KTAP is not installed or the modules were not specified during the installation.

Environment

Linux

Diagnosing The Problem

Any of the following may be noticed-

  • There may be errors in some of the log files (eg. /tmp/guard_stap.stderr.txt on the DB Server ) that state that the KTAP file is missing.
        /dev/guard_ktap: No such file or directory
  • In the guard_tap.ini file on the DB Server the following parameter may be set as 0
        ktap_installed=0
  • The inspection engine will not have all of the required settings.
        From the GUI , Administration Console->Local Taps->S-Tap Control->Inspection Engines
          The setting options that are likely to be missing are DB Process Name and DB Install Dir.

        In the guard_tap.ini file on the DB Server the following parameters may not be set
            db_exec_file
            db_install_dir
  • The STAP is not collecting any traffic.

Resolving The Problem

GIM Installation


Non-GIM Installation

    If you installed the STAP without GIM you may need to reinstall the STAP and ensure that you include the following step from the STAP help book or Infocenter - eg

    Installing an S-TAP on UNIX and the section marked
      Installing an S-TAP from the Command Line

If either of these steps do not help (GIM OR Non-GIM installation) contact IBM Guardium Technical Support so that they can check that there is a KTAP module available for your Linux Kernel.

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Document Information

Modified date:
16 June 2018

UID

swg21660372