IBM Support

Informix content store failing to install when performing an easy install in IBM Cognos analytics 11

Troubleshooting


Problem

When choosing to perform an Easy Install in Cognos Analytics 11, although the wizard states the installation was completed successfully. When navigating to <cognos_location>\Informix, it is confirmed empty and when testing the content store in Cognos Config it returns "[ERROR] Content Manager is unable to connect to the content store ...."

Cause

The user chose to point the easy install to a directory in a Drive different than Drive C in Windows. By design, there is a limitation in the Informix ifxdeploy utility that causes the installation to fail when the target directory is located in a drive with Short File Names disabled which is the case by default for all drives other then C in Windows (created manually). 

Resolving The Problem

There are two possible resolutions:
 
A: Either re-perform the install in Drive C.
 
B: Or, uninstall Cognos and enable Short File Names in the desired drive, you can do so by following the steps below (this is a suggestion, if it didn't work please refer to Windows documentation/support):
  1. Open CMD (ensure to run as administrator)
  2.  Let's assume the chosen drive is D, use the file system utility command to find out the current status of Short File Name in it. The command format is the following: fsutil 8dot3name query D:
    If Short File Name is disabled, the output will be similar to the one below:
    The volume state is: 1 (8dot3 name creation is disabled).
    The registry state is: 2 (Per volume setting - the default).
    Based on the above two settings, 8dot3 name creation is disabled on d:
  3. To enable SFN, execute the following command: fsutil 8dot3name set D: 0
  4. If done successfully, you should get this response: Successfully set 8dot3name behaviour.
  5. You can double check by re-executing the command from step 2... The output now will be similar to the one below:
    The volume state is: 0 (8dot3 name creation is enabled).
    The registry state is: 2 (Per volume setting - the default).
    Based on the above two settings, 8dot3 name creation is enabled on c:
Now, re-install Cognos and it Informix should install successfully.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 January 2020

UID

ibm10871638