IBM Support

Incorrect status of web server shown in the WebSphere Application Server administrative console

Troubleshooting


Problem

The WebSphere Application Server administrative console can sometimes show the wrong status for the web server. It might show "started" (green arrow) when the web server is really stopped. Or it might show "stopped" (red x) when the web server is really started.

Symptom

When you start an IBM HTTP Server web server from the administrative console, it might give an error message saying that the web server was not started, when in reality it was started successfully.

Cause

In order to determine the status of the web server, the administrative console attempts to establish a socket connection to the web server port. If the socket connection is successful, then the administrative console shows the web server status as "started" (green arrow). However, if the socket connection is unsuccessful, then the administrative console shows the web server as "stopped" (red x).

Resolving The Problem

If the administrative console is showing the web server status as "started", when in fact the web server is stopped, it means that the administrative console was able to successfully establish a socket connection to the hostname and port number defined for that web server. This can happen when some other software is listening for socket connections on that port. This can also happen with certain firewalls which accept socket connections on that port before attempting to actually connect to the web server. Check the web server definition in the administrative console to ensure that it is using the correct hostname and port number. Check the ports on the web server system (netstat -an) to see if something else is listening on that port. Check the firewall between the web server and WebSphere Application Server Deployment Manager to see if it might be sending a "false positive" by accepting the socket connection on that port.

If the administrative console is showing the web server status as "stopped", when in fact the web server is started, it means that the administrative console was unable to establish a socket connection to the hostname and port number defined for that web server. This can happen when something (for example, firewall) is blocking the connection. Check the web server definition in the administrative console to ensure that it is using the correct hostname and port number. Check the web server configuration to ensure that it is using the same port number as defined in the administrative console. Check the firewall between the web server and WebSphere Application Server Deployment Manager to ensure that the port is open so that administrative console can connect to the web server port.


Related information
Troubleshooting WebSphere Application Server and IBM HTTP Server administrative console problems

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Document Information

Modified date:
15 June 2018

UID

swg21431586