IBM Support

Inbound Shipment purge is purging shipments even when the order is not purged

Troubleshooting


Problem

Attempts to run shipment purge is purging shipments from YFS_SHIPMENT table and moving them to History table even though the corresponding orders are not yet purged in IBM Sterling Order Management.

Symptom

Steps to reproduce:

  1. Create a PO for 2 qtys.

     
  2. Record receipt on this PO. Receive only 1qty.
    A shipment gets created without a shipment line.


     
  3. Close the shipment. Shipment is in receipt closed status.

     
  4. Run shipment purge, the shipment is purged. The order is still active.

Cause

Order to shipment association is through shipment lines. Hence shipment getting purged is independent of the order.

Diagnosing The Problem

If you are processing a receipt it should be against a shipment having a shipment line.  In this case, a PO is created and then Report/Record receipt is done which has no relation to a shipment. You do not have a actual shipment that is being processed.  Since no shipment information is passed, system internally creates a dummy shipment since receipt processing has to happen on a shipment, but this dummy shipment requires no shipment lines as the receipt lines already have the required information.
 

Resolving The Problem

To resolve,  create shipments and then process the purchase order. This way shipments are created with shipment lines

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Document Information

Modified date:
11 February 2020

UID

ibm10719501