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Inbound email: multiple consumers for the same endpoint is not allowed

Troubleshooting


Problem

Configured inbound email, tests successfully and no emails in the inbox. 

Symptom

resilient-email.log

[Camel (camel-1) thread #1 - JmsConsumer[email-service.create-connection]] ERROR v=unknown c.r.e.CreatedUpdatedMailboxBuilder - Error related to message queue_email-service.create-connection_ID_XXX on route "mailbox-config-jms-add-email-route"

org.apache.camel.FailedToStartRouteException: Failed to start route Org <XXX> Mailbox X because of Multiple consumers for the same endpoint is not allowed: imaps://mail.xxx.com:xxxxxx@example.com)&consumer.bridgeErrorHandler=true

Cause

The same inbound email settings cannot be configured for the same organization or different organizations. The inbound email setting must be unique. 

Resolving The Problem

  1. Use different email address for different org(s)
  2. Use different "source folder" for the email address. For example, one uses "folder1", and the other uses default "inbox".

Document Location

Worldwide

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Document Information

Modified date:
22 October 2021

UID

ibm16507131