Troubleshooting
Problem
If there are non-ASCII characters in the ReqIF import file path, the import operation cannot be completed.
Symptom
Cause
DOORS does not support non-ASCII characters in the path when you reference files.
Environment
All Microsoft Windows clients.
Resolving The Problem
- Solution 1:
Change the ReqIF file location.
- Solution 2:
If you cannot change the file location, create a virtual drive without non-ASCII characters that use the Windows subst command. Map the problem path to an unmapped drive.
① Open the Windows command line prompt and use the subst command.
Example: (Where J is an unmapped drive)subst j: C:\Users\Administrator\Desktop\サポート
② You can see the J drive and ReqIF file in Windows Explorer.
③Select a file in the J drive and open it.
④ There is no problem to open it.
The virtual drive letter disappears upon restart. If you want to keep it after you restart, create a BAT file with the command and register it in the Windows startup program.
Alternatively, you can add a registry key.For all usersREGEDIT4[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices]
"J:"="\\??\\C:\\Users\\Administrator\\Desktop\\サポート"For an individual user
REGEDIT4
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
"J Drive"="subst J: C:\\Users\\Administrator\\Desktop\\サポート"
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"ARM Category":[{"code":"a8m50000000Ciw8AAC","label":"ERM DOORS-\u003EImport"}],"ARM Case Number":"TS014106423","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions"}]
Product Synonym
DOORS
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Document Information
Modified date:
11 September 2023
UID
ibm17031047