Troubleshooting
Problem
Customer tries to import data from staging tables. Afterwards, user opens the batch queue to see how the job progressed. Inside the section "status" the message "Finished with Error" appears.
Symptom
Unfortunately, when you double-click on the entry "Finished with Error", inside the 'Details Section' the text might be empty / blank / white:
Therefore it is not easy to see why the import failed.
Cause
There are several different possible causes for similar symptoms.
- TIP: For more examples, see separate IBM Technote #2010454.
This Technote specifically relates to the scenario where the cause is a defect (reference APAR PI81283) in Controller 10.3.0 FP1 IF4 (10.3.1.53) and earlier.
- For more details, see separate IBM Technote #1497825.
Diagnosing The Problem
In order to see the root cause's error message, perform the following task:
1. Modify the import specification so that 'Track Data' is enabled (ticked):
2. Re-run the import
3. Ask your database administrator (DBA) to look in the Controller database's table: xbatchqueue
4. Locate the row where the batch ID relates to your failed job
5. Look inside the column: errtext
6. After you have successfully found the root cause of the problem, remember to disable 'Track Data'. This is to reduce the strain on the application server.
Example:
In one real-life example, the error was similar to:
The statement has been terminated.
Violation of PRIMARY KEY constraint ´PKNC_XDB19´. Cannot insert duplicate key in object ´dbo.xdb19´. The duplicate key value is (1901BU, 12345, EUR, 45678W , , , , , , , , 0, ,
Violation of PRIMARY KEY constraint ´PKNC_XDB19´. Cannot insert duplicate key in object ´dbo.xdb19´. The duplicate key value is (1901BU, 12345, EUR, 45678W , , , , , , , , 0, ,
Resolving The Problem
Fix:
Upgrade to either:
Upgrade to either:
- Controller 10.3.0 FP1 IF5 GA (also known as version 10.3.1.60) or later 10.3.0 version
- or Controller 10.3.1 (also known as version 10.3.1100.156) or later.
Workarounds:
See separate IBM Technote #2010454.
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1, 10.3.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
31 January 2019
UID
ibm10869756