Troubleshooting
Problem
In step 1 of probe for email document for TLS connection
https://www.ibm.com/support/knowledgecenter/SSSHTQ/omnibus/probes/email/wip/reference/email_keystore_file.html
the command
keytool -import -alias client_certificate -file certificate_file -keystore keystore_name
give error of "java.lang.Exception: Input not an X.509 certificate"
Cause
A wrong certificate type was used.
A version of .cer certificate is expected. Using a certificate of .p7b will give the error.
Diagnosing The Problem
Check to make sure the certificate used is of .cer type.
Resolving The Problem
Convert the .p7b certificate file to x.509 (.cer) certificate file using Microsoft Windows
- Copy the .p7b certificate file to a Windows desktop
- Rename the PKCS 7 certificate and give it a .p7b extension if need to.
- Open the .p7b file
- Click the plus ( + ) symbol
- Click the Certificates directory
- Right click on your certificate file
- Select All Tasks > Export
- Click Next
- Select Base-64 encoded X.509 (.cer) > Click Next
- Browse to a location to store the file
- Enter a File name. For example MyCert. The .cer extension is added automatically
- Click Save
- Click Next
- Click Finish
Alternatively use openssl
openssl pkcs7 -print_certs -in certificatename.p7b -out certificatename.cer
Used the converted .cer certificate to import into your keystore.
Document Location
Worldwide
[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSSHTQ","label":"Tivoli Netcool\/OMNIbus"},"Component":"Probe for Email","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Historical Number
TS002639718
Product Synonym
email probe
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Document Information
Modified date:
11 September 2019
UID
ibm11073494