Troubleshooting
Problem
Unable to search orders being fulfilled from other stores despite 'Include orders being fulfilled by other stores' is checked.
Symptom
Steps to reproduce:
1. Create 2 stores (N1 and N2). Create user N1U1 under the store N1.
2. Create an order Order1 with ShipNode as N1. Schedule & release it.
3. Create a shipment. Shipment moves to 'Ready for backroom pick' status.
4. Repeat steps 2,3 for order Order2 with ShipNode as N2.
5. Login to Sterling Store with user N1U1. In Backroom Pick widget, click Advanced Search link.
6. Check 'Include orders being fulfilled by other stores' option & click Search.
Actual Result: In Search Results, only order Order1 appears instead of both orders Order1 & Order2.
Cause
The Node User & Data Access Policy Rules configuration is incomplete.
Environment
IBM Sterling Web Store 9.5
Resolving The Problem
Following two configurations are necessary in order to search orders from other stores.
A. Create a Team that has Ship Node Access to other stores & assign it to Node User
Steps:
1. Launch Application Platform. Go to Security > Teams.
2. Create a new Team (e.g. Multi_Store_Team). In Ship Node Access tab, select 'All Nodes'. Save changes.
3. In Application Platform, click on the hammer icon & select the Node (e.g. N1) then click Ok.
4. Go to Security > Users. Search user (e.g. N1U1) & double click on it.
5. In User Details, select the Team (e.g. Multi_Store_Team) & Save changes.
B. Node User should be given access to Nodes assigned to their team
Steps:
1. Launch Application Platform. Go to Security > Data Access Policy Rules.
2. In Node User tab, select 'Users Have Access To Nodes Assigned To Their Team'. Save changes.
With above configuration changes, Node User should be able to search orders from other stores.
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Document Information
Modified date:
30 October 2018
UID
ibm10735669