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IBM Security Guardium Installation Manager (GIM) Installation fails with error: "Can't locate gim installation directory. Verify GIM is defined as an init service"

Troubleshooting


Problem

When running the IBM Security Guardium™ Installation Manager (GIM™) installation script, the installation fails and the process exits presenting an error message.
Verifying archive integrity... All good. Uncompressing Guard BUNDLE-GIM Installer.... perl used : /usr/bin/perl
This product is subject to the license terms associated with the IBM Security Guardium product purchased.
Installing modules .... Can't locate gim installation directory. Verify GIM is defined as an init service...
Another similar error message that suggests the same problem is:
Verifying archive integrity... All good.
Uncompressing Guard BUNDLE-GIM Installer....

GIM installation directory not found : ...

Symptom

The GIM™ installation fails with one of the error messages displayed at the Problem section of this page.

Cause

The most common cause is a previously existing corrupted GIM™ installation where the "/etc/inittab" file still contains references to the GIM™ and SUPERVISOR services.

Environment

  • GIM™ version: any.
  • GIM™ operating systems: the issue has been identified mainly in the AIX™ operating system family, but it may occur in any environment where the operating system implements the SysV init facility. Check with your system administrator, or the corresponding system documentation, if you need to validate if the SysV init is being used.

Diagnosing The Problem

Try to run the GIM™ installation script.
It will fail and present one of the error messages documented hereby.

Resolving The Problem

Note 1. The process must be executed using the root account of the operating system.
1. Look at the "/etc/inittab" file and check if there are any records related to the GIM™ ("gim_client") and SUPERVISOR ("guard_supervisor") services.
You can use any standard Linux/UNIX commands, for example, the "grep" utility.
grep -Eni "gim_client.pl|guard_supervisor" /etc/inittab
Example.
image 8141
2. If you find any lines related to the GIM™ software, edit the "/etc/inittab" file to remove them.
Again, use any Linux/UNIX tools of your choice.
3. Run the "init q" command from the shell, so the changes made to the inittab file are effective.
init q
4. Try to install the GIM™ once again.
Example.
image 8143
Tip 1. It is advisable that you get familiar with the product documentation of the version of your choice to know the valid options and values of the GIM™ installation script, and reduce the likely of issues.
The picture above showing a successful installation is merely referential.

Document Location

Worldwide

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Document Information

Modified date:
03 February 2021

UID

ibm16409988