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IBM Security Guardium - Accessing Data Activity returns "Failed to load data" error

Troubleshooting


Problem

While using IBM Security Guardium Central Manager, we access the Guardium menu:

Investigate -> Search for Data Activity

The data is unable to load into any of the tabs(Activity, Outliers, Errors, Violations) at the top of the page.

 

Symptom

The below error is returned to the window when trying to access any of the tabs(Activity, Outliers, Errors, Violations) on the page(Investigate -> Search for Data Activity):

"Failed to load data!"

When you try to access any of the tabs a new window is generated showing the error:

"Error SyntaxError: Expected ')' "

Cause

This is due to the csrf_status being disabled on the Guardium Central Manager but enabled on the Guardium Collectors.

Environment

 

 

Diagnosing The Problem

To further diagnose the problem execute the cli command on your IBM Security Guardium Central Manager:

show gui csrf_status

You will see the below output returned from the Central Manager:

Disabled

 

 

Resolving The Problem

In order to resolve the problem simply enabled the crsf status in each environment:

store gui csrf_status on

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Component":"Data Activity","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.1.3;10.1.4;10.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
25 July 2018

UID

ibm10718797