IBM Support

IBM Rational Rhapsody help does not open on Red Hat 7

Troubleshooting


Problem

On computers running Red Hat 7, the Rhapsody help application does not open when run.

Symptom

When the help application is run from within the Rhapsody user interface or from a command-line, a small splash-size window is displayed but the help itself does not open.

Cause

This problem occurs when the help application cannot locate a 64-bit JRE to use.

Resolving The Problem

To correct this problem:

  1. Open the file help.ini located in (rhapsody installation directory)\Doc\Help
  2. The -vm argument in the file uses the path: ../../jdk/jre/bin
  3. Replace "../../jdk/jre/bin" with the path to the 64-bit Java executable on your computer
  4. Save the modified help.ini file.
  5. Try starting the help again.

[{"Product":{"code":"SSB2MU","label":"IBM Engineering Systems Design Rhapsody"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF016","label":"Linux"}],"Version":"8.2","Edition":"Rational Rhapsody Architect for Software;Rational Rhapsody Architect for Systems Engineers;Rational Rhapsody Designer for Systems Engineers;Rational Rhapsody Developer","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Product Synonym

Rational Rhapsody

Document Information

Modified date:
27 May 2022

UID

swg21993761