Troubleshooting
Problem
In IBM Maximo Application Suite - Admin console when viewing the debug information for an application, an error message is displayed in the downloaded logs in place of the logs themselves.
Symptom
Error is showed: An unexpected exception occurred while getting debug information
Cause
Proper permissions are not set.
Diagnosing The Problem
- Go to: https://admin.<masinstance>.domain/applications/manage
- Click in details in one of the status tiles
- Click Download debug information
A log file is downloaded and contains a permission error message:
HTTP response body:
b'{"kind":"Status","apiVersion":"v1","metadata":{},"status":"Failure","message":"pods is forbidden: User \\"system:serviceaccount:mas-xxxxxx-core:ibm-mas-coreapi\\" cannot list resource \\"pods\\" in API group \\"\\" in the namespace \\"mas-xxxxxxx-manage\\"","reason":"Forbidden","details":{"kind":"pods"},"code":403}\n'
Resolving The Problem
Add the verb "list" to the pod resource in the ibm-mas-coreapi-base:<mas instanceid> cluster role, as follow:
[...]
- verbs:
- get
- list
apiGroups:
- ''
resources:
- pods
- pods/log
[...]
Problem is addressed by known issue DT243960.
Document Location
Worldwide
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Document Information
Modified date:
07 December 2023
UID
ibm17091467