Troubleshooting
Problem
Launching the IBM Knowledge Center® server application from the commandline "startKC.bat" script file fails to start the server.
Symptom
![image 8205](/support/pages/system/files/inline-images/image_8205.png)
Cause
The error shown above was produced when using the latest Oracle JDK in the JAVA_HOME variable:
![image 8209](/support/pages/system/files/inline-images/image_8209.png)
This JDK version is not supported.
IBM Knowledge Center application® requires a supported JDK version to build and run the application.
Resolving The Problem
The JAVA_HOME variable must be set to a working JDK and it must be the correct version. To gurrantee this last point, it is recommended to use the JDK shipped with the IBM product. In this instance, IBM Rhapsody®. For example:
![image 8206](/support/pages/system/files/inline-images/image_8206.png)
![image 8208](/support/pages/system/files/inline-images/image_8208.png)
Document Location
Worldwide
[{"Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSB2MU","label":"IBM Engineering Systems Design Rhapsody"},"ARM Category":[{"code":"a8m0z000000cwOlAAI","label":"IBM Knowledge Center Application"}],"ARM Case Number":"TS004906638","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
Was this topic helpful?
Document Information
Modified date:
27 May 2022
UID
ibm16413287