IBM Support

IBM Installation Manager reports error "Could not retrieve installation minimum service level (MSL) file information" when attempting to install Service Component Architecture (SCA) Fix Pack 1.0.1.3 and an interim fix such as PM12705

Troubleshooting


Problem

When attempting to install Fix Pack 1.0.1.3 for the Service Component Architecture (SCA) Feature Pack for WebSphere Application Server V7.0, the IBM Installation Manager reports an error "Could not retrieve installation minimum service level (MSL) file information". The Installation Manager might also display a NullPointerException. This occurs when attempting to install the fix pack concurrently with an interim fix, such as interim fix PM12705.

Symptom

When attempting to install Fix Pack 1.0.1.3 for the Service Component Architecture (SCA) Feature Pack for WebSphere Application Server V7.0, the IBM Installation Manager reports an error. If you are using the IBM Installation Manager's graphical interface (wizard) to install the fix, you will see an error appear at the top of the window which looks like one of the following examples:

When attempting to install the Feature Pack for the first time



The error text says "Could not retrieve installation minimum service level (MSL) file information".


When attempting to update the Feature Pack using Fix Pack 1.0.1.3



The error text says "Could not retrieve installation minimum service level (MSL) file information". The text has been highlighted with yellow coloring in this example screenshot.


When attempting to install or update the Feature Pack in silent mode
If you are installing maintenance in silent mode, you will see an error appear at the console which is similar to the following:

Exception in thread "Thread-50" java.lang.NullPointerException
com.ibm.was.msl.prereq.core.MSLMaintenanceState.
getValidOfferingVersionPairFromJobs(MSLMaintenanceState.java:216)
com.ibm.was.msl.prereq.core.MSLMaintenanceState.
initialize(MSLMaintenanceState.java:45)
com.ibm.was.msl.prereq.core.DetectMinimumServiceLevel$MSLMaintenanceThread.
run(DetectMinimumServiceLevel.java:221)

Cause

This issue is specific to the Service Component Architecture (SCA) Feature Pack Fix Pack 3 (version 1.0.1.3).

Due to a packaging issue in the fix pack, it is not possible to install the fix pack concurrently with an interim fix.

This error is most likely to occur when attempting to install Interim Fix PM12705 with SCA Fix Pack 1.0.1.3. Interim fix PM12705 is required for clients interested in using the new business object runtime framework offered as a Technology Preview in WebSphere Process Server V7.0.0.2. The fix PM12705 itself does not have an issue, but IBM Installation Manager cannot install it until after SCA Fix Pack 1.0.1.3 is successfully installed.

Resolving The Problem

You must install interim fixes for Service Component Architecture (SCA) Feature Pack Fix Pack 3 (version 1.0.1.3) after the fix pack is successfully installed. Avoid attempting to install the interim fixes at the same time that the fix pack is installed.

Solution when using the graphical interface (wizard)
If you are installing SCA Fix Pack 1.0.1.3 using the IBM Installation Mananger's graphical user interface (the installation wizard), then resolving this issue is straightforward.

  1. Using IBM Installation Manager, begin the process of installing or updating the SCA Feature Pack.

  2. When you are prompted with the list of packages which are eligible to be installed, look for the category labeled, "WebSphere Application Server V7 Feature Pack for Service Component Architecture (SCA) 1.0.1.0". In that category, "Version 1.0.1.3" represents Fix Pack 3 for SCA.

    If any interim fixes (such as "PM12705 1.0.1.3") are listed under "Version 1.0.1.3", make sure those fixes are de-selected. (If you want to install Fix Pack 1.0.1.3, then be sure that "Version 1.0.1.3" remains selected.)

  3. Proceed through the remaining panels to install or update the SCA Feature Pack. Once the process successfully completes, then SCA should be updated with Fix Pack 1.0.1.3.

    Do not exit IBM Installation Manager yet; instead, navigate back to the main menu.

  4. Click Update on the main menu.

  5. When prompted, you can now select interim fixes under the SCA "Version 1.0.1.3" category.

  6. Proceed through the remaining panels to install the interm fix. The fix should install successfully.



Solution when using the silent installation (using a response file)
If you are installing SCA Fix Pack 1.0.1.3 using IBM Installation Manager's silent installer, then you can resolve this issue by editing the response file.

Interim fixes for SCA Fix Pack 1.0.1.3 are typically installed using local repositories. As a result, the local repository for the interim fix (such as PM12705) is located in a directory that you chose. You would have added the location to this repository to your response file yourself.

In order to resolve this issue, edit the response file. Remove the reference to the interim fix's local repository. For example, if the local repository were located in "/downloads/PM12705", then you would search for and remove this line from the response file:

<repository location='/downloads/PM12705'/>

Once this repository location is removed from the response file, you can then proceed to run the silent installation. It will update SCA with Fix Pack 1.0.1.3.

Once this is complete, you can add the repository location to the response file again. Then, you can run the silent installation again. It will install the interim fix onto SCA Fix Pack 1.0.1.3.



Additional information
This is recognized as a known issue with the way SCA Fix Pack 1.0.1.3 is packaged. The next Fix Pack for SCA will not have the same issue, and it will allow interim fixes to be installed concurrently with that next Fix Pack.

Due to this issue, interim fixes for SCA Fix Pack 1.0.1.3 will not be published to the live repositories on ibm.com. (The live repositories are also called "service repositories" or "online repositories".) The interim fixes will not be available on the live repository because automated installation scenarios automatically attempt to install fixes from the live repository, and this issue causes those automated installations to fail.

Interim fixes for SCA Fix Pack 1.0.1.3 will still be made available for download from ibm.com, but you will need to manually download the interim fixes and use IBM Installation Manager to install them from a local repository.

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Document Information

Modified date:
15 June 2018

UID

swg21430189