Troubleshooting
Problem
Attempting to save or search in IBM FileNet P8 Content Engine (CE) is slow and sometimes hangs.
Symptom
CE exhibits slow performance and hangs. Datasource errors appear in the logs, but the database is fine and the datasources test out ok in the WAS console.
Cause
Too few connections in the datasource connection pool
Environment
WebSphere Application Server
Diagnosing The Problem
Errors such as this appear in the logs:
2015-05-19T08:12:21.412 1F7122D0 CSTG FNRCE0024E - ERROR
executeRollFwdCommand threw an exception
com.filenet.api.exception.EngineRuntimeException: FNRCE0024E:
E_FAILED_TO_GET_DATASOURCE: The server cannot get the data source
<name>. Message was: CWTE_NORMAL_J2CA1009
Resolving The Problem
Increase the number of connections in the Connection pool:
- Access the WebSphere Integrated Console: http://server_name:9060/ibm/console (default) where server_name is the name of your CE server.
- Navigate to Resources -> JDBC -> Data sources.
- Click each data source and check the Connection pool properties value,
which is on the right side of the page. - Increase the Connection pool based on your system resources and needs. A suggested maximum value is 100.
- Click OK.
- Click Save directly to the master configuration.
- Restart WebSphere
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Document Information
Modified date:
17 June 2018
UID
swg21903591