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Troubleshooting
Problem
When searching for files using IBM Content Navigator's (ICN) search feature, files that are expected to be returned are missing. However when running a similar search using FileNet Content Platform Engine's (CPE) native search, correct results are returned.
Symptom
Searching for "TEST" in ICN:
Returns no results:
In CPE, the search works as expected:
Cause
A possible cause is that the search created by ICN is not compatible with CPE's search syntax. This can occur when CPE client files have not been updated to the correct CPE version during the ICN install or upgrade.
Environment
IBM Content Navigator 2.0.x
IBM FileNet Content Platform Engine 5.2.x
Diagnosing The Problem
1. To diagnose the issue, enable debug logging on the ICN server:
Instructions
- Open the Admin Desktop in ICN
- Click the Settings and go to the Logging tab
- From Application-level Logging dropdown, select Debug.
- Save and close.

2. Run a search in ICN as normal:

3. Open the application server log for the server where ICN is deployed. Example:

4. In the log, search for "sql:" and find the line that best matches the search that has been ran:

- The text following "sql:" is the statement ICN sends to CPE in order to initiate the search:
SELECT t.[DocumentTitle], t.[ContentSize], t.[LastModifier], t.[DateLastModified], t.[MajorVersionNumber], t.[ClassDescription], t.[IsCurrentVersion], t.[IsReserved], t.[Reservation], t.[MimeType], t.[VersionStatus], t.[MinorVersionNumber], t.[VersionSeries], t.[Id], t.[ReplicationGroup], t.[Creator], t.[ReservationType], t.[IsVersioningEnabled], t.[Owner], t.[EntryTemplateObjectStoreName], t.[EntryTemplateId], t.[EntryTemplateLaunchedWorkflowNumber], t.[CompoundDocumentState] FROM [document] t WHERE t.[DocumentTitle] LIKE 'TEST%' AND t.VersionStatus = 1 ORDER BY t.[DocumentTitle] OPTIONS (TIMELIMIT 60, COUNT_LIMIT 2147483647 )

Resolving The Problem
Steps to upgrade the CPE client files are provided in the Infocentre at the link below:
Updating the IBM FileNet P8 client connector files (FileNet P8)
[{"Product":{"code":"SSEUEX","label":"IBM Content Navigator"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ICN and CM FileNet","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.0.2;2.0.3","Edition":"","Line of Business":{"code":"LOB18","label":"Miscellaneous LOB"}},{"Product":{"code":"SSEUEX","label":"IBM Content Navigator"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ICN and CM FileNet","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.0.3;2.0.2","Edition":"","Line of Business":{"code":"LOB18","label":"Miscellaneous LOB"}}]
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Document Information
More support for:
IBM Content Navigator
Software version:
2.0.2, 2.0.3
Operating system(s):
Linux, Windows
Document number:
544415
Modified date:
17 June 2018
UID
swg21978583
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