IBM Support

"IBM Cognos" service fails to start correctly (with "CFG-ERR-0106", "CAM-CRP-1095 Unable to find the encryption certificate with alias 'encryption'", "The certificate alias encryption..." errors) caused by expired cryptographic keys

Troubleshooting


Problem

Administrator logs on to Cognos Analytics server, and launches 'Cognos Configuration'. Administrator clicks the 'Start' button (to start the IBM Cognos service).
Initially appears to start working OK. However, soon afterward the progress screen stops updating. The Windows service IBM Cognos shows 'Starting' but the service does not successfully start.

Symptom

Screen:
The service stops updating the screen:
image 3934
[Launching a JVM 'Maximum memory in MB']
Successfully launched a test JVM with the memory setting of '2048'. Note there is no guarantee that the IBM Cognos service start and run successfully. 
To see which JVM options are based on the setting, view ibmcognos_location/bin64/bootstrap_wlp_<OS>.xml and see your JVM documentation for an explanation of those options.
[Start Service]
16:22:32, 'LogService', 'StartService', 'Success'.
[Start Service]
[ERROR] CFG-ERR-0106 IBM Cognos Configuration did not receive a response from the IBM Cognos service in the time allotted.
Check that IBM Cognos service is available and properly configured.
Logs:
Entries in the CA log similar to:
cognosserver.log
Error initializing CAMCrypto CAM-CRP-1095 Unable to find the encryption certificate with alias 'encryption' in the keystore 'C:/Program Files/ibm/cognos/analytics/configuration/certs\CAMkeystore'.
 
ffdc_<date>.log
------Start of DE processing------ = [5/29/20 16:22:29:223 BST]
Exception = java.lang.IllegalArgumentException
Source = com.ibm.ws.ssl.provider.IBMJSSEProvider
Probeid = getKeyTrustManagers
Stack Memory Dump = java.lang.IllegalArgumentException: CWPKI0024E: The certificate alias encryption specified by the property com.ibm.ssl.keystoreServerAlias is not found in keystore C:/Program Files/ibm/cognos/analytics/configuration/certs/CAMkeystore.jks.

Cause

The Cognos Analytics cryptographic keys are expired.

Resolving The Problem

Regenerate the Cognos Analytics cryptographic keys.
Steps:
For full details on how to regenerate cryptographic keys, see separate IBM technote #286475.
However, the following 'simplified' steps are suitable under the following circumstances:
  • Cognos Analytics (CA) is installed into the default location
  • Therefore, the procedure was not previously completed (the folders do not exist, otherwise you get errors)
1. Launch a Command (as an administrator)
image 3935
6. Copy and paste the following commands:
REM Script v3 (27/08/2020) RC
REM Export current configuration to an XML file
cd "C:\Program Files\ibm\cognos\analytics\bin64"
cogconfig.bat -e "C:\Program Files\ibm\cognos\analytics\configuration\backup.xml"
 
REM Remove current crypographic keys/information
md "C:\Program Files\ibm\cognos\analytics\configuration\backup_to_fix_problem"
move "C:\Program Files\ibm\cognos\analytics\configuration\cogstartup.xml" "C:\Program Files\ibm\cognos\analytics\configuration\backup_to_fix_problem"
move "C:\Program Files\ibm\cognos\analytics\configuration\caSerial" "C:\Program Files\ibm\cognos\analytics\configuration\backup_to_fix_problem"
move "C:\Program Files\ibm\cognos\analytics\configuration\certs\CAMCrypto.status" "C:\Program Files\ibm\cognos\analytics\configuration\backup_to_fix_problem"
move "C:\Program Files\ibm\cognos\analytics\configuration\certs\CAMkeystore" "C:\Program Files\ibm\cognos\analytics\configuration\backup_to_fix_problem"
move "C:\Program Files\ibm\cognos\analytics\configuration\certs\CAMkeystore.lock" "C:\Program Files\ibm\cognos\analytics\configuration\backup_to_fix_problem"
move "C:\Program Files\ibm\cognos\analytics\temp\cam\freshness" "C:\Program Files\ibm\cognos\analytics\configuration\backup_to_fix_problem"
ren "C:\Program Files\ibm\cognos\analytics\configuration\backup_to_fix_problem"
cd "C:\Program Files\ibm\cognos\analytics\configuration"
ren csk csk_backup_to_fix_problem
 
REM Copy new configuration
copy "C:\Program Files\ibm\cognos\analytics\configuration\backup.xml" "C:\Program Files\ibm\cognos\analytics\configuration\cogstartup.xml"
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
IMPORTANT: You must remember to press <ENTER> on your keyboard entering these commands, otherwise the final command does not be executed (and so the fix will not be successful)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
7. Launch 'Cognos Configuration'
image 5722
8. Click the 'Save' button (near the upper left)
  • The cryptographic keys to get regenerated (which normally takes a few minutes)
9. Afterward, click the 'Start' (or 'Restart') button (near the upper left) to start the service.

Document Location

Worldwide

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Document Information

Modified date:
28 January 2023

UID

ibm16218328