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IBM COGNOS FOR MICROSOFT OFFICE 11 CONNECTION USING OFFICE 2016 EXCEL™ , POWERPOINT ™ , WORD ™ LOGIN BLANK PAGE POST WINDOW ®10 BUILD 1809 UPDATE

Troubleshooting


Problem

Following Microsoft ® Windows 10 OS Build 1803 or higher update with Microsoft Office 365 Build 1808. Access IBM Cognos for Microsoft Office 11 and connection to gateway URI with Microsoft ® Office 365 Excel™, PowerPoint™, or Word ™ 2016.
Observe a blank page with no details for IBM Cognos login page with Namespace, User-ID, and Password fields.
Expect to observe a COM pop-up window within Microsoft ® Office Excel™, PowerPoint™, Word™ 2016 for IBM Cognos Analytics 11 login page with Namespace, User-ID, and Password fields.
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Symptom

  i. Connect by using gateway URI, observe a COM pop-up window within Microsoft ® Office Excel™, PowerPoint™, or Word™ 2016, observe a blank page with no details for IBM Cognos login page.
Unable-To-Login-PowerPoint-Pop-Up-Window-Only
Unable to close Excel™, PowerPoint™, or Word™ application. Require to kill or terminate the application by using Windows Task Manager.
 ii. Click the IBM Cognos for Microsoft Office Application toolbar button, the right IBM pane to display the list of folders is also blank.
IBM-Cognos-Microsoft-Office-COM-Folders-Blank
iii. Observed post Microsoft ® Windows 10 OS Build 1803 or higher following Windows OS update that uses Microsoft ® Office 365 Build 1808 or higher.

Cause

Issue related to Microsoft ® Office 365 not doings well with non-HDPI displays with COM objects.
Microsoft ® introduced a feature in Microsoft ® Office 2016 for Windows that dynamically scales the application window to adjust for when you move Office apps back and forth between high and low DPI monitors. This feature is on, by default, in Office 2016 and Office 2019 on Windows 10.
However, observed odd display behavior with certain third-party add-ins like COM add-ins where the add-in draws in the wrong location or draws as an incorrect size.

Environment

Microsoft ® Windows 10 OS Build 1803 or higher
Microsoft ® Office 365 Build 1808 or higher using Excel™, PowerPoint™, or Word™
IBM Cognos for Microsoft Office 11
IBM Cognos for Planning Analytics for Excel

Diagnosing The Problem

Refer to Symptoms.

Resolving The Problem

Improve drawing problems with add-ins by changing the display settings to compatibility mode. To change the display settings for Office go to File > Options > General.
Refer to section "Use Office compatibility mode"
Change the Options -> General -> User Interface options -> "When using multiple displays" = Optimize for compatibility.
Office-Options-General-Optimize-Compatinility
Restart Excel™, PowerPoint™ or Word™ for changes to take effect.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"IBM COGNOS ANALYTICS FOR MICROSOFT OFFICE 11\nIBM COGNOS ANALYTICS FOR EXCEL","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.x","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
05 August 2019

UID

ibm10964848