IBM Support

IBM Cognos LifeCycle Manager session times out

Troubleshooting


Problem

A Cognos LifeCycle Manager session can time out regardless of any activity a user might be performing.

Symptom

Cognos LifeCycle Manager becomes unresponsive.

Cause

Cognos LifeCycle Manager uses IBM WebSphere Application Server Liberty as a server. The Cognos LifeCycle Manager Liberty server is configured to use IBM WebSphere Lightweight Third-Party Authentication (LTPA). Cognos LifeCycle Manager sessions are managed by a LTPA token. By default, the LTPA token expires after two hours regardless of any activity a user might be performing at the two hour mark. As a result, Cognos LifeCycle Manager sessions will time out after two hours.

Resolving The Problem

Any tasks that Cognos LifeCycle Manager is performing at the two hour mark will continue to run. To initiate a new action, users must clear their browser cache and log in again, or restart the server.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21992382