Troubleshooting
Problem
IBM Cognos Analytics Content Manager fails to start.
Symptom
Messages looking like the following are logged into cogaudit.log:
<![CDATA[Invalid entry (CMID=1460054): invalid parent (PCMID=1438645)]]>
Cache errors detected. Please run consistency check
The particular numbers in CMID= and PCMID= could be different.
Running configuration/schemas/content/<db type>/dbMakeConsistent.sql does not resolve the issue.
Cause
The Content store is inconsistent
Resolving The Problem
- Collect all the CMID numbers mentioned in the invalid entry messages
- If number of invalid entries is significant log a support ticket to asses if the following steps would delete important objects reports, for instance, and restoring the Content store from a backup is a safer option.
- Delete rows in CMOBJECTS table in the Content store database where CMID equals any of the invalid entry CMID
- Execute the dbMakeConsistent.sql and AddConsistencyFixFlag scripts from the folder configuration/schemas/content/<db type> of the Content Manager installation in the Content store database
- Start Content Manager
Document Location
Worldwide
[{"Type":"SW","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6YAAS","label":"Installation and Configuration->Content Manager"}],"ARM Case Number":"TS005397433","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
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Document Information
Modified date:
22 April 2021
UID
ibm16446189