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IBM Cloud Pak for Business Automation (CP4BA) Case-init job fails with exception java.lang.Exception: Creation of ICM Plugins failed

Troubleshooting


Problem

The case-init job which is supposed to update the Case Manager components fails to complete.
Due to this failure, some parts of CP4BA are unusable.

Symptom

The case-init job's pod Websphere Liberty messages.log file contains the following:

INFO: Your session expired.
Log in again.
Your session expired because of inactivity. java.lang.Exception: Creation of ICM Plugins failed at com.ibm.ecm.icm.config.init.ConfigureNavigator.createNavigatorArtifacts(ConfigureNavigator.java:49) at com.ibm.ecm.icm.config.init.InitCaseManager.main(InitCaseManager.java:28) Mar 13, 2024 12:24:16 PM com.ibm.ecm.icm.config.init.InitCaseManager main SEVERE: Case Init failed java.lang.Exception: Creation of ICM Plugins failed at com.ibm.ecm.icm.config.init.ConfigureNavigator.createNavigatorArtifacts(ConfigureNavigator.java:49) at com.ibm.ecm.icm.config.init.InitCaseManager.main(InitCaseManager.java:28)

Cause

Checking the Business Automation Navigator (BAN) pod's log file shows the following warning at the time when case-init job fails:
[03/14/24 17:01:34:622 UTC] 00000026 SystemOut  O CIWEB Debug: [] [REQUEST 562] com.ibm.ecm.configuration.ApplicationConfig._getMatchedIgnoreCase() User o=defaultWIMFileBasedRealm/{USERNAME} is not an administrator
[03/14/24 17:01:34:623 UTC] 00000026 SystemOut  O CIWEB Warn : [] [REQUEST 562] com.ibm.ecm.struts.actions.GetDesktopAction.desktopConnect() User o=defaultWIMFileBasedRealm/{USERNAME} does not have access to the Admin application

Diagnosing The Problem

Some parts of the case-init job relies on BAN to be configured correctly.
Monitor the BAN pod's log while the case-init job is running to catch any issues within BAN.
1) Determine which user is running the case-init job by reviewing the job's .yaml file
2) Run the following OC commands to determine the administration users set for BAN and IBM Filenet Content Process Engine (CPE); Replace {CP4BA-namespace} with your actual namespace name.

a) oc -n {CP4BA-namespace} get secret ibm-ban-secret -o jsonpath='{.data.appLoginUsername}' | base64 -d && echo > BANuser.txt

b) oc -n {CP4BA-namespace} get secret ibm-fncm-secret -o jsonpath='{.data.appLoginUsername}' | base64 -d && echo > FNCMuser.txt
3) All of the users above should match.

4) Login to the BAN administration desktop > Administrators
In the Administrators section, the user who runs the case-init job should be in list of BAN administrators.

Resolving The Problem

1) Determine which user is running the case-init job by reviewing the job's .yaml file
2) Run the following OC commands to determine the administration users set for BAN and IBM Filenet Content Process Engine (CPE); Replace {CP4BA-namespace} with your actual namespace name.

a) oc -n {CP4BA-namespace} get secret ibm-ban-secret -o jsonpath='{.data.appLoginUsername}' | base64 -d && echo > BANuser.txt

b) oc -n {CP4BA-namespace} get secret ibm-fncm-secret -o jsonpath='{.data.appLoginUsername}' | base64 -d && echo > FNCMuser.txt
3) All of the users above should match, make the necessary changes if required.

4) Login to the BAN administration desktop > Administrators
In the Administrators section, make sure that the user who runs the case-init job is in the list of BAN administrators, add them if required.
5) Save changes
6) Delete the case-init job pod and wait for it to be recreated by the controller. (may take 30 minutes)

Document Location

Worldwide

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Product Synonym

CP4BA; CP4A; BAN; CPE; p8;

Document Information

Modified date:
27 March 2024

UID

ibm17145342