Troubleshooting
Problem
After you migrate IBM Business Process Manager servers and the IBM Business Process Manager database to V8.5.0, a database communication error is seen.
Symptom
The following errors are reported when the server starts:
com.ibm.mm.server.persistence.rdbms.dao.ibatis.BaseDaoreadPathByPath BMWSD0429E: An SQLException was encountered while communicating with the database. Error code: 0, SQL State: null, Message: Error: executeQueryForObject returned too many results.
The default Process Portal spaces and templates are not loaded.
Cause
Multiple nodes in the cell attempt to load the default spaces and templates.
Resolving The Problem
If you have an environment with the Business Space component (for Process Portal) installed on multiple managed nodes in a cell, start only one node first and start the other nodes only after the first node has already started.
Product Synonym
BPM
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21638941