IBM Support

IBM APM 8.1.4 : TMOUT variable should not be set when you run the APM server install.sh script

Troubleshooting


Problem

After installing the IBM Application Performance Management SERVER v8.1.4 on Linux, you are seeing that not all APM server processes or services are started; some are stopped and could not be started; some services are also missing.
Example:

[root@<host>#‌ apm status

Service ksy is started (PID 15914).

Service kafka is started (PID 17764).

Service spark is started (PID 18330).

Service txagent is started (PID 21828).

Service scr is started (PID 23345).

Service oidc is started (PID 23570).

Service server1 is started (PID 23910).

Service min is started (PID 24722).

Service apmui is started (PID 25730).

Service oslc is stopped.

Service uviews is started (PID 31552).

Symptom

1)

Not all the 16 processes expected to be available on a APM 8.1.4  server are defined and installed. Installation is incomplete.

2)

/opt/ibm/ccm/logs/apm-server-install_<date>.log

simply ends with the line:

...

...

Executing com.ibm.apmsaas.CreateTablesFromODI, details in /opt/ibm/ccm/logs/PrefetchDB_create_from_ODI.log

 3)

Service oslc is stopped. Such service is unable to start .. From oslc_pm/logs , there is this error reported:

KASPR005E The OSLC-PM Service Provider could not connect to the Registry Services server. All KAS_REGISTRY_SERVICES_URL_xxx parameters must be defined.

4)

/opt/ibm/ccm/logs/apm-verbose.log

shows:

[15444] Service oslc is stopped.

Starting service oslc

apm_start returns 2

Processing. Please wait...

Starting the Tivoli Enterprise Monitoring Automation Server...

Failure: Agent failed to start. Check the agent start log.

Executed /opt/IBM/IPM8/ccm/oslc_pm/bin/itmcmd agent start as, rc=2

apm_start returns 2

5)

/opt/ibm/ccm/oslc_pm/logs/<host>_as_<timestamp>.log

shows:

KASSRV032 Tivoli Enterprise Monitoring Automation Server startup complete.

KASE058  Using default KAS_REGISTRY_SERVICES_TIMEOUT_GET timeout 120 second(s).

KASE058  Using default KAS_REGISTRY_SERVICES_TIMEOUT_POST timeout 120 second(s).

KASE058  Using default KAS_REGISTRY_SERVICES_TIMEOUT_DELETE timeout 120 second(s).

KASE050  Web Service Started... Service Name kas_srv_kas.

KASS001  Program provider.bin is started.

KASPR039E The configuration setting KAS_REGISTRY_SERVICES_URL_PROTOCOL is missing.

KASPR005E The OSLC-PM Service Provider could not connect to the Registry Services server. All KAS_REGISTRY_SERVICES_URL_xxx parameters must be defined.

Cause

Possible cause is that the TMOUT environment variable is set up in the terminal session in use for the APM server installation.
Normally after a complete APM server installation, you should get 16 services up and running, like example here:

[root@xxx ccm]# apm status

Service db2 is started (PID 8190).

Service ksy is started (PID 8724).

Service kafka is started (PID 10014).

Service spark is started (PID 1164).

Service txagent is started (PID 14511).

Service mongodb is started (PID 16181).

Service scr is started (PID 16521).

Service oidc is started (PID 16714).

Service server1 is started (PID 17246).

Service min is started (PID 21451).

Service apmui is started (PID 23523).

Service oslc is started (PID 5380).

Service dqe is started (PID 6666).

Service uviews is started (PID 7045).

Service biagent is started (PID 11613).

Service soagent is started (PID 23660).

[root@xxxxx ccm]#

Environment

APM SERVER v8.1.4 on LINUX; for example, on Red Hat Enterprise Linux (RHEL) Server 7 x86-64, and update v7.6

Diagnosing The Problem

Run the command :
$> env
on the APM server, in the terminal session in use and where the install.sh program is launched,  and verify that the TMOUT environment variable is not declared.
Example:

[root@<host> ibm]#‌ env

HOSTNAME=xxxx

SHELL=/bin/bash

TERM=xterm-256color

HISTSIZE=5000

OLDPWD=/root

HISTFILESIZE=5000

USER=root

LS_COLORS=rs=0:di=38;5;27:ln=38;5;51:mh=44;38;5;15:pi=40;38;5;11:so=38;5;13:do=38;5;5:bd=48;5;232;38;5;11:cd=48;5;232;38;5;3:or=48;5;232;38;5;9:mi=05;48;5;232;38;5;15:su=48;....

ENV=/root/.kshrc

TMOUT=600

MAIL=/var/spool/mail/root

PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/lpp/mmfs/bin:/root/bin

PWD=/opt/ibm

EDITOR=vi

LANG=en_US.UTF-8

HISTCONTROL=ignoredups

SHLVL=1

HOME=/root

LOGNAME=root

LESSOPEN=||/usr/bin/lesspipe.sh %s

EXTENDED_HISTORY=ON

HISTTIMEFORMAT=%D%T -

HISTFILE=/var/adm/commandlog/history_xxxx_root_from_apmadmin_xxxxx

_=/bin/env

Resolving The Problem

1)
uninstall the incomplete APM server that was installed, following documentation instructions:
2)
Remove the TMOUT variable, using unset command:
$> unset TMOUT
 it should remove TMOUT from environment variables.
verify using env command again
3) install again the APM server using these details steps. If an issue persists, then you can open a case , using IBM Support website, and provide data collected from steps here:
3a) Uncomment the set -x line near the top of the install.sh script

3b) ./install.sh 2>&1 | tee /tmp/install-output.log

3c) If the Linux 'strace' command is available on your server, run these commands in a separate console window while the install.sh script is running:

3c1) ps -ef | grep "install.sh"     

3c2) strace -p <pid>

where <pid> is the install.sh process ID seen from step 3c1

If an issue persists and still APM server installation failed, send to IBM support:

- The /tmp/install-output.log file from step 3b

- The strace command output (if strace is enabled) from step 3c2

 - Run:

$> /opt/ibm/ccm/collectLogs.sh

and provide the output file.

For reference, IBM Support website:

https://www.ibm.com/mysupport/s/?language=en_US

select option : Open a case if needed.

Document Location

Worldwide

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSVJUL","label":"IBM Application Performance Management"},"ARM Category":[{"code":"a8m500000008axGAAQ","label":"APM Server"}],"ARM Case Number":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"8.1.4","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

TS003252906

Product Synonym

APM;IPM;

Document Information

Modified date:
08 April 2020

UID

ibm11569663