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IBM APM 8.1 WAS agent - how to troubleshoot WAS server issue after WAS agent was installed?

Troubleshooting


Problem

Using IBM APM 8.1.4 WAS agent (product code YN), how to troubleshoot WebSphere Application Server's issue encountered after WAS agent was installed and configured?

Symptom

IBM WebSphere Application Server application is not reachable any more, after WAS agent and its data collector were installed and enabled.

Cause

Possible cause is that the Data Collector has broken something within WebSphere Application Server.

Environment

Red Hat Enterprise Linux (RHEL) version 7
WebSphere Application Server Traditional version 8.5.5
YN Monitoring Agent for Websphere Applications version 07.30.14.10

Diagnosing The Problem

Unconfigure manually the data collector, following the IBM knowlegde center link:
If the issue is addressed after above step was applied and WAS server was restarted, it proves that it's the data collector that is causing the issue.

Resolving The Problem

If you have determined that it is the data collector that is causing the issue, then

reconfigure on the WAS server the APM 8.1 WAS agent and enable the Data Collector :

https://www.ibm.com/support/knowledgecenter/SSHLNR_8.1.4/com.ibm.pm.doc/install/was_config_fast_track.html

and reproduce the issue again.

Then, referring to APM knowledge Center link below

https://www.ibm.com/support/knowledgecenter/SSHLNR_8.1.4/com.ibm.pm.doc/install/was_config_liberty_dc_disable_bci.html

Apply the detailed steps below:

1. disable the JDBC instrumentation

go to the directory location:

/opt/ibm/apm/agent/yndchome/{dc_version}/runtime/<was_instance>/custom

for example:

/spatrol/apm/yndchome/7.3.0.14.02/runtime/was85.JazzSMNode01Cell.JazzSMNode01.JazzSMProfile.server1/custom

2. In the custom directory, update the toolkit_custom.properties file and

add the following property:

com.ibm.tivoli.itcam.toolkit.ai.enablejdbc=false

3. Restart the WAS server's JVM.

Notice :If the issue is not fixed, and your WAS application is still not working, collect the related data collector logs for further investigation.

for example, run:

/opt/ibm/apm/agent/lpl266/yn/bin/kyncollect.sh

It will produce an archive file, which contains the data collector main config files and logs.

You can then engage IBM support, or review the data collector logs to try and find out some clues on what is not right.

You can also refer to this other article for collecting more artifacts from WAS agent:

https://www.ibm.com/support/pages/node/1084317?lang=en&

Similarly as step 1 above, and as documented

https://www.ibm.com/support/knowledgecenter/SSHLNR_8.1.4/com.ibm.pm.doc/install/was_config_liberty_dc_disable_bci.html

you can try to disable other Byte Code Instrumentation's (BCI) type of Java EE API, like EJB, or JSP, or RMI, etc and see if that helpas further with your issue.

Document Location

Worldwide

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Historical Number

TS003546302

Product Synonym

apm

Document Information

Modified date:
14 April 2020

UID

ibm16189753