Troubleshooting
Problem
Symptom
There was an error connecting the share or the server. Make sure the lsdev command shows that device nsmb0 is in the Available state. Also make sure that the share name, user name and password are accurate.
Cause
- The string "cifs".
- The forward slash character "/".
- The lowercase, short host name of the SMB server.
- A period ".".
- The Kerberos realm name, in lowercase, specified with the wrkgrp mount option.
Diagnosing The Problem
user:debug smbcd: smbfs_gssAuthenticate: Returning smbfs_gssGetSessionKey gt.gerror:851968
kern:err|error unix: smb_smb2_ssnsetup: gerror = D0000
- The Kerberos error codes "-1765328343" or "-1765328377", which can appear instead as "96C73A29" or "96C73A07".
![image 7432](/support/pages/system/files/inline-images/image_7432.png)
Resolving The Problem
![image 7434](/support/pages/system/files/inline-images/image_7434.png)
SNameString
values with a "/" character to form the SPN.setspn
command or with the Active Directory Users and Computers snap-in. In both cases, the account to which the SPN must be added is the computer account for the Kerberos server. It is typically located in the "Domain Controllers" folder in the snap-in and is the short host name of the server. For example, if the SPN is "cifs/smbsrv1.ad.us.domain.com" and the Kerberos server name is "adsrv1", use this setspn
command.setspn -S cifs/smbsrv1.ad.us.domain.com adsrv1
![image 7438](/support/pages/system/files/inline-images/image_7438.png)
SUPPORT: If the instructions in this document do not lead to resolution of the problem, follow these instructions to open a case. The product must be under warranty or have an active and valid support contract. a. Document or take screen captures of all symptoms, errors, or messages. b. Capture any logs or data relevant to the issue. c. Contact IBM® to open a case. -For electronic support, visit the IBM Support Community: d. Provide a detailed description of the issue and reference this technote. e. Upload all of the details and data to the case. -You can attach files to the case in the IBM Support Community, or http://www.ibm.com/support/docview.wss?uid=ibm10733581 f. Click here to submit feedback for this document. |
Related Information
Document Location
Worldwide
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Document Information
Modified date:
24 March 2022
UID
ibm16380146