Troubleshooting
Problem
When trying to login into iBase or Designer, there is a login failure for a userid different than the id used to login when trying to open an upsized ibase database. The details shows the following:
Login failed for user 'xxxxxxx'. [ Details << ] Error #3149 occurred in: Microsoft OLE DB Provider for SQL Server idDBEngine:mGetADOConnection idDBEngine:Connect idDBConnection:Connect idDBSystem:OpenDB idDBSystem:OpenDatabase FMain:DoCommand FMain:DoCommand(DatabaseOpen)
Cause
In the iBase Configuration of the upsized iBase database, the SQL Server connection id used for the iBase server to connection to the SQL Server database has a password which has not been updated after the change of the password in the SQL Server Security.
Resolving The Problem
Launch the iBase Database Configuration utility from the Windows Start Programs list under IBM i2 iBase 8.
Identify your Security file (.ids) and your iBase database file (.idb) and specify an iBase admin user such as SYSADMIN.
Here's an example:
In the next screen you will see the SQL Server id used to connect to your ibase database. This is where you need to update the password of the SQL connection id:
Save the updated password with the checked option to "Test connection before saving". If the connection succeeds then you should now be able to connect using iBase and Designer.
Document Location
Worldwide
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Historical Number
TS002285421
Product Synonym
ibase; designer
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Document Information
Modified date:
31 May 2019
UID
ibm10885833