IBM Support

HTTP Server does not redirect browser URI to <alias>/bi/ in Cognos Analytics

Troubleshooting


Problem

If the Browser does not automatically redirect to /alias/bi then you may have to make changes to the webcontent\default.htm document.

Symptom

Browser does not redirect to correct URL.

Cause

Default document may need to be modified.

Environment

Windows

IIS

Resolving The Problem

1. On the Web Server machine, open the /<Cognos Analytics Installation Directory>/webcontent directory in Windows Explorer.

2. Make a backup of the default.htm

3. Edit default.htm in a text editor.

4. Update the last entry to be similar to:
<meta http-equiv="refresh" content="0; URL=/<aliasName>/bi/">

If you are upgrading from Cognos Analytics 11.0.3 to Cognos Analytics 11.0.4 (or later) and you had modified server.xml to configure

an sso/login path pointing to /ibmcognos/cgi-bin/cognosisapi.dll, remove this entry from install_location/wlp/usr/servers/cognosserver/server.xml


<jndiEntry jndiName="glass/sso/login" value="/ibmcognos/cgi-bin/cognosisapi.dll"/>

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21994150