IBM Support

"HRESULT: 0x80010105 (RPC_E_SERVERFAULT)" when trying to open more than one data entry form

Troubleshooting


Problem

User launches Microsoft Excel. User clicks 'Controller - Logon' and logs into Controller. User clicks 'Controller - Data Entry'. User fills in the required fields (for example Actuality, Period, Company, Currency Type, Submission and Form) and then clicks 'Open'. The data entry form opens OK. User keeps the data entry form open, but then switches back to the main Controller program. ser clicks 'Controller - Data Entry'. User fills in the required fields (for example Actuality, Period, Company, Currency Type, Submission and DIFFERENT Form) and then clicks 'Open'. An error message appears.

Symptom

Error #1
Microsoft Office Excel
Microsoft Office Excel has encountered a problem and needs to close. We are sorry for the inconvenience.
The information you were...
<....>
[Send Error Report] [Don't Send]

Error #2
Information
Standard Error
Source: ControllerForms
Description: The server threw an exception. (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))
at Cognos.Controller.ControllerForms.frmDataEntrySelection.OpenExcelForm(OpenType OpenHow)
at Cognos.Controler...
[OK]

Cause

There are several potential causes for the "(Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))" error.

  • For more examples, see separate IBM Technote #1574387.

This Technote specifically relates to the scenario where the problem is caused by a third-party (Microsoft) bug in their Excel 2007 product.
  • For more details, see separate IBM Technote #1394945.

Environment

Client device has Excel 2007 installed, but does not have *both* of the following patches installed:

  • MS Office 2007 SP2
  • MS Hotfix 974992

Resolving The Problem

Fix:

Upgrade the client device (for example end user's PC and/or Microsoft Terminal/Citrix server) to the following Microsoft Office patch level:

  • Microsoft Office/Excel 2007 Service Pack 2 (SP2)
  • *plus* Microsoft hotfix KB 974992 (released by Microsoft on October 27th 2009).

Steps:

  1. Logon to the client device as an administrator
  2. Download and install MS Office 2007 SP2 (TIP: This file is also known as "office2007sp2-kb953195-fullfile-en-us.exe")
  3. Download the MS Office 2007 post-SP2 hotfix from http://support.microsoft.com/kb/974992
  4. Extract and then install the file (TIP: The extracted file is also known as "office-kb974992-fullfile-x86-glb.exe")

Workaround:

Open the second form via the "Excel link" add-in (instead of using the 'main' Controller program's menu item).

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21503045