Troubleshooting
Problem
On ISAM appliance when attempting to use the Policy Administration tool through the Local Management Interface (LMI), the error "HPDJA0116E Cannot contact server. (0x307a8074)" is received and login is not successful. However, login and use of pdadmin through the appliance Command Line Interface (CLI) is working fine.
Cause
The appliance was hosting the Policy Server and had undergone a hostname change since intial deployment when the Runtime Component was configured. Although the pd.conf configuration file had been edited to reflect the new hostname after the change, there is no way to update the "/usr/lib/jvm/ibm-jre/PolicyDi
Diagnosing The Problem
Collect a Support File from the appliance and review and compare the following configuration entries which should match and reflect the current Policy Server hostname (or IP address):
- The "appsvr-plcysvrs=" specification in file /usr/lib/jvm/ibm-jre/PolicyDi
rector/PD.properties - The "master-host = " specification in file /var/PolicyDirector/etc/pd.conf
If the entries do not match then you have the problem as described in this technote.
Resolving The Problem
Contact IBM Support and request fixpack "update_pd_properties.fixpack" which when installed on the appliance, performs a one-time sync of Policy Server hostname and port settings from pd.conf to PD.properties file to correct the mismatch.
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Document Information
Modified date:
09 October 2018
UID
ibm10734453