Question & Answer
Question
How does the IBM Daeja ViewOne annotationAutoSave parameter work with the Daeja ViewOne Viewer, IBM Content Navigator, IBM Case Manager and IBM Business Automation Workflow?
Cause
The behavior experienced with the Daeja ViewOne annotationAutoSave parameter will differ depending on how the parameter is set and the user actions taken in the viewer and surrounding applications.
Answer
annotationAutoSave parameter determines whether annotations are saved automatically. If this parameter is set to true, users are not prompted to save annotations. Instead, annotations are sent automatically to the server-side save object. If this parameter is set to false, the user is prompted to save annotations. The parameter applies when the viewer is closed by a web page change, or when the document is closed by an open or close action. The default value of this parameter is false.
You need to set this parameter on ICN admin -> Settings -> Daeja ViewONE -> Virtual.
ICN admin Settings of Daeja ViewONE from IBM Case Manager:
ICN admin Settings of Daeja ViewONE from IBM Business Automation Workflow:
The following screen capture shows annotations created in IBM Case Manager:
The following screen capture shows annotations created in IBM Business Automation Workflow:
Auto save with annotations works for IBM Content Navigator and stand-alone Daeja Virtual viewer that uses parameter annotationAutoSave set to true, that means, when you open a document and create an annotation and if you click on the x in the upper right corner to close the screen it does the auto save.
With Case Manager and IBM Business Automation Workflow, when you click on the X button on the upper right corner to close the screen, it auto saves the annotations if the IBM Daeja ViewOne annotationAutoSave parameter is set to true.
But if you click on the close button to close the Case , you get a warning pop-up message, which is expected behavior as shown:
IBM Case Manager Warning pop-up:
IBM Business Automation Workflow warning pop-up:
annotationAutoSave works with IBM content navigator and Daeja stand-alone viewer but it does not work in the same way with IBM Case Manager or IBM Business Automation Workflow when you close the Case, which is expected. You need to close the Daeja viewer window in order for annotationAutoSave to work.
[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTTN8","label":"IBM Daeja ViewONE Virtual"},"ARM Category":[{"code":"a8m50000000L2oyAAC","label":"Technote"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
28 October 2021
UID
ibm16509336