Troubleshooting
Problem
Planning Analytics Web Tier crash (TM1 Application Server, TM1 Web, Spreadsheet Service)
Cause
If one of your Planning Analytics Web Tier applications is suddenly unavailable, it is possible that it crashed. A crash can occur due to a problem with the application, however is more often driven by exhausting the resources allocated for the application server.
The majority of TM1 Application Server crash issues are related to usage, resources, or a combination of both. For example, a number of new users have been introduced - and the Application Server now consumes more memory. Or perhaps, websheet design is not following best practice and leads to issues with memory consumption.
The steps in this document cover the collection of details IBM Support requires to assist with diagnosing the problem.
Resolving The Problem
In the event of a Planning Analytics Web Tier crash, collect the following:
- Basic description of the problem.
- What was it that users were doing when the problem occurred?
- Was it limited to just one user, or all users?
- This may not always be available. Sometimes there is too much activity on the server to know which action triggered the crash – or that users were simply working as they normally do, when the problem occurred.
- Although difficult, anything we can do to better understand the steps are activity leading to the crash allows us to more easily identify the cause and solution.
- Entire \install_dir\logs\ directory
- From the crashing application directory
- The primary log file is tm1_messages.log / messages.log
- GarbageCollection log file
- Found in \install_dir\bin64\ as verbosegc_TIMESTAMP.log
- See: http://www-01.ibm.com/support/docview.wss?uid=swg22002245
- Any recent javacore* files
- Found in \install_dir\bin64\ directory
- If the javacore file contains OutOfMemoryError within, the crash encountered is related to resources
- Review the following: How to Manage your TM1 Web Tier (JAVA) Memory
- Any recent *.hpd files
- Found in \install_dir\bin64\ directory
- tm1web.log
- Found in \install_dir\webapps\tm1web\WEB-INF\logs\
- pmpsvc.log
- Found in \install_dir\webapps\pmpsvc\WEB-INF \logs\
- tm1server.log
- Location defined in the affected server's tm1s.cfg file
- tm1top.log
- Location defined by TM1Top or tm1s.cfg
- tm1s.cfg
- Typically resides in or near your TM1 Data directory
- cmplst.txt
- Found in \install_dir\
[{"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2.0.1;2.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
03 May 2022
UID
swg22002285